📌 Improve your Angular CLI skills with this free Angular CLI course on Pluralsight

Problem Scenario and Error Message

I was attempting to add a sitemap.xml file to my Scully/Angular app.

I ran the npm install command:

npm install @gammastream/scully-plugin-sitemap --save-dev

Then I updated my scully config file to configure the plugin based on this Sitemap plugin documentation on scully.io.

After installing the plugin I ran into this error when attempting to build my scully application:

Cannot find module 'fast-xml-parser'

Solution

The solution to resolve this error is to install the 'fast-xml-parser' package by running the following command:

npm install fast-xml-parser

After the npm package for fast-xml-parser is installed you will no longer see the error!

📌 Improve your Angular CLI skills with this free Angular CLI course on Pluralsight
Related Blog Posts